Hi folks, In our methodology, I think it would be quite rare to have a cumbersome select prefix - we're going to do our inline constraining in some kind of testcase-specific driver object and the object we're randomizing will be a local data member of that driver class or a function automatic which we access using a simple name. Our testbench people expect to use Neil's syntax, and don't see a problem with it. The real issue I'm concerned about is not how to explicitly specify binding into the object, but how to explicitly specify binding into the local lexical scope. I think that's where we need the enhancement. --Mike Gordon Vreugdenhil wrote: > > > Neil Korpusik wrote: >> Jonathan Bromley wrote On 10/23/07 01:45 AM,: >>> (7) In a modification of suggestion (2): instead of putting >>> a list of names in the parens, provide just one identifier, >>> freely chosen by the programmer, which is to be treated as >>> an alias for the object being randomized: >>> obj.randomize() with (thing) {thing.x < thing.y + x;}; >>> >> >> Perhaps I am missing something here. >> >> Why can't we just use the following? Since obj is the thing >> being randomized, why can't we just use 'obj.' when we need to >> specify that the variables used in the with clause are within obj? >> >> obj.randomize() with {obj.x < obj.y + x;}; > > Neil, I think that this would effectively remove the current > special rules. In addition, this is painful if "obj" is a general > select prefix -- users would want/need to create a temporary handle > of the appropriate type to have manageable constraints. > > Gord. > > > -- This message has been scanned for viruses and dangerous content by MailScanner, and is believed to be clean.Received on Fri Oct 26 18:04:30 2007
This archive was generated by hypermail 2.1.8 : Fri Oct 26 2007 - 18:05:05 PDT