Jonathan Bromley wrote On 10/23/07 01:45 AM,: > (7) In a modification of suggestion (2): instead of putting > a list of names in the parens, provide just one identifier, > freely chosen by the programmer, which is to be treated as > an alias for the object being randomized: > obj.randomize() with (thing) {thing.x < thing.y + x;}; > Perhaps I am missing something here. Why can't we just use the following? Since obj is the thing being randomized, why can't we just use 'obj.' when we need to specify that the variables used in the with clause are within obj? obj.randomize() with {obj.x < obj.y + x;}; Neil -- This message has been scanned for viruses and dangerous content by MailScanner, and is believed to be clean.Received on Tue Oct 23 13:53:15 2007
This archive was generated by hypermail 2.1.8 : Tue Oct 23 2007 - 13:53:46 PDT