Skip Nav
Home » Forums » SystemC Forum

Icon - KMLM List KMLM List

View email archives for the history of this mailing list.

List Home All Archives Dates Threads Authors Subjects
systemc-forum - Re: [systemc-forum] compiling systemc in linux..!! Message Thread: Previous | Next
  • To: Muhammed Salman <salmanmanekia@xxxxxxxxx>
  • From: Sumit Adhikari <sumit.adhikari@xxxxxxxxx>
  • Date: Fri, 24 Jul 2009 19:24:28 +0530
  • Cc: alan.fitch@xxxxxxxxxx, systemc-forum@xxxxxxxxxxxxxxxxx
Send Email to systemc-forum@lists.systemc.org:
Send new message
Reply to this message
Hello Muhammed,
 Try gcc 4.2.1. This works well. Also check :
  g++ -v (On existing 4.3.1)
From this you will find out the configuration options. Compile your new gcc with those configutaion options.
Hope your problems will be solved.
Let me know if you have further issues. I had same kind of problem with gcc and I have fixed them like I described on the top.
BR,
Sumit

*P.S. : Just checked mail from Bas. I have a patch for Qt fix for -m32 option. If you require I can give it to you.*








Muhammed Salman wrote:
hello alan
the gcc version installed in my system is 4.3.1..i guess it is not compatible with the systemc version i am working on..i have tried to install gcc 3.2.3 now..but its throwing some weird errors which hopefully will be solved soon...
i have removed the comment from this statement
#@(cd ./examples; $(MAKE) install;)
and executed the make install but it didnt had any effect ,still the example folder has makefile....and no makefile.defs..
Thanks



--- On *Wed, 7/22/09, alan.fitch@xxxxxxxxxx /<alan.fitch@xxxxxxxxxx>/* wrote:


    From: alan.fitch@xxxxxxxxxx <alan.fitch@xxxxxxxxxx>
    Subject: Re: [systemc-forum] compiling systemc in linux..!!
    To: "Muhammed Salman" <salmanmanekia@xxxxxxxxx>
    Cc: systemc-forum@xxxxxxxxxxxxxxxxx
    Date: Wednesday, July 22, 2009, 1:52 AM

    Hi Muhammed,

      after installing systemc, if you look in the objdir you had to
    create,
    there is a Makefile there.

    In that Makefile, there is a line

    #@(cd ./examples; $(MAKE) install;)

    which has been commented out. I guess that if you remove the #
    from that
    line and run "make install" again,
    it will create the Makefile and Makefile.defs for the examples.  I
    don't
    know why it's been commented out.
    I've copied this to the forum in case someone else knows.

    Regarding your second question, it should be possible to copy a
    Makefile
    and Makefile.defs, as long as you check
    all the paths in the Makefile and Makefile.defs are still correct.

    On  our courses, the Makefiles always use relative paths so you
    can copy
    the whole exercise
    anywhere you like and it still works.

    I normally put a Makefile.defs in my home directory, then include
    it with

    include ~/Makefile.defs

    then I only need one Makefile.defs for all projects

    regards
    Alan


-- Alan Fitch
    Senior Consultant

    Doulos - Developing Design Know-how
    VHDL * Verilog * SystemVerilog * SystemC * PSL * Perl * Tcl/Tk *
    Project
    Services

    Doulos Ltd. Church Hatch, 22 Market Place, Ringwood, Hampshire,
    BH24 1AW,
    UK
    Tel:  + 44 (0)1425 471223                       Email:
    alan.fitch@xxxxxxxxxx </mc/compose?to=alan.fitch@xxxxxxxxxx>
    Fax:  +44 (0)1425 471573                        http://www.doulos.com

    
--------------------------------------------------------------------------------
    Doulos Ltd is registered in England and Wales with company no. 3723454
    Its registered office is 4 Brackley Close, Bournemouth International
    Airport,
    Christchurch, BH23 6SE, UK.

    This message (and associated files) may contain information that is
    confidential,
    proprietary, privileged, or subject to copyright. It is intended
    solely
    for the use
    of the individual to whom it is addressed and others authorised to
    receive
    it. If
    you have received this email in error, please notify the sender
    and delete
    all
    copies. This message may contain personal views which are not the
    views of
    Doulos, unless specifically stated.




    From:
    Muhammed Salman <salmanmanekia@xxxxxxxxx
    </mc/compose?to=salmanmanekia@xxxxxxxxx>>
    To:
    Alan Fitch <alan.fitch@xxxxxxxxxx
    </mc/compose?to=alan.fitch@xxxxxxxxxx>>
    Date:
    22/07/2009 09:41
    Subject:
    Re: [systemc-forum] compiling systemc in linux..!!




    i will try this and come back to u..
    i am also confused with these questions
    1, In the user guide which comes with systemc installation it says
    under
    the headline of 'compiling the example for linux'
    ..that copy the makefile and makefile.defs from systemc installation
    example directory...
    but in example directory i only found makefile.in and makefile.am
    ...and
    in the sysc subdirectory i have only makefile.defs...so its sort of
    confusing that where actually to find makefile...
    2,in the last few days i tried to implement the examples given in the
    example folder and it worked fine...i then copied the
    makefile.defs from
    the example folder and tried to modify it with respect to my
    program(i.e
    changing the directory location,cpp files and h files) but this
    trick also
    didnt worked...so is it a conceptual mistake to do this sort of
    copying or
    should i be looking into some minor details in makefile.defs..
    thanks for all your help...
    Regards
    -Muhammad Salman
    --- On Mon, 7/20/09, Alan Fitch <alan.fitch@xxxxxxxxxx
    </mc/compose?to=alan.fitch@xxxxxxxxxx>> wrote:

    From: Alan Fitch <alan.fitch@xxxxxxxxxx
    </mc/compose?to=alan.fitch@xxxxxxxxxx>>
    Subject: Re: [systemc-forum] compiling systemc in linux..!!
    To: "Muhammed Salman" <salmanmanekia@xxxxxxxxx
    </mc/compose?to=salmanmanekia@xxxxxxxxx>>
    Cc: systemc-forum@xxxxxxxxxxxxxxxxx
    </mc/compose?to=systemc-forum@xxxxxxxxxxxxxxxxx>
    Date: Monday, July 20, 2009, 8:26 AM

    Muhammed Salman wrote:
    > Hello,
    > How to simulate the design in systemc when working in linux,i
    mean does
    one has to use testbench file etc.
    > and can one take a look at these errors
    >
    >
    /home/salman/systemc-2.2.0/include/sysc/datatypes/bit/sc_lv_base.h:
    In
    member function 'sc_dt::sc_logic_value_t
    sc_dt::sc_lv_base::get_bit(int)
    const':
    >
    /home/salman/systemc-2.2.0/include/sysc/datatypes/bit/sc_lv_base.h:310:

    warning: suggest parentheses around arithmetic in operand of |
    > g++  -Wall -Wno-char-subscripts -Wno-return-type -Wno-deprecated
    -g -O0
    -I. -I.. -I/home/salman/systemc-2.2.0/include
    -I/apps/TLM-2005-04-08/tlm
    -L. -L.. -L/home/salman/systemc-2.2.0/lib-linux -Xlinker -rpath
    -Xlinker
    /home/salman/systemc-2.2.0/lib-linux -o run.x Main.o Reciever.o
    Sender.o
    channel.o dataPacket.o -lstdc++ -lm  -lsystemc 2>&1 | c++filt
    >
    
Main.o(.gnu.linkonce.t._ZN7sc_core8sc_inoutI10dataPacketE18end_of_elaborationEv+0xed):

    In function `sc_core::sc_inout<dataPacket>::end_of_elaboration()':
    >
    
/home/salman/systemc-2.2.0/include/sysc/communication/sc_signal_ports.h:1124:

    undefined reference to `sc_trace(sc_core::sc_trace_file*, dataPacket
    const&, std::basic_string<char, std::char_traits<char>,
    std::allocator<char> > const&)'
    >
    
Main.o(.gnu.linkonce.t._ZN7sc_core5sc_inI10dataPacketE18end_of_elaborationEv+0xb6):

    In function `sc_core::sc_in<dataPacket>::end_of_elaboration()':
    >
    /home/salman/systemc-2.2.0/include/sysc/communication/sc_signal_ports.h:285:

    undefined reference to `sc_trace(sc_core::sc_trace_file*, dataPacket
    const&, std::basic_string<char, std::char_traits<char>,
    std::allocator<char> > const&)'
    >  does it means the code is wrong or it has something to do with if
    systemc is not correctly installed...
    >
    > Thanks
    >

    Hi Muhammed,
    sorry for the delay, I've been out of the office. If the code
    compiles
    correctly under Windows with Visual C++, then I guess it may be
    related to
    using an up-to-date version of gcc.

    Is it possible to test with an older version of gcc?

    regards
    Alan


    -- Alan Fitch
    Senior Consultant

    Doulos ? Developing Design Know-how
    VHDL * Verilog * SystemVerilog * SystemC * PSL * Perl * Tcl/Tk *
    Project
    Services

    Doulos Ltd. Church Hatch, 22 Marketing Place, Ringwood, Hampshire,
    BH24
    1AW, UK
    Tel:  + 44 (0)1425 471223        Email: alan.fitch@xxxxxxxxxx
    </mc/compose?to=alan.fitch@xxxxxxxxxx>
    Fax:  +44 (0)1425 471573        http://www.doulos.com

    ------------------------------------------------------------------------

    This message may contain personal views which are not the views of
    Doulos,
    unless specifically stated.







--

--------------------------------------------
Sumit Adhikari
System Design Engineer
austriamicrosystems AG
Business Unit : Automotive
Mob : 00-91-9885271710/00-91-9000161710



By Date: Previous | Next Current Thread By Thread: Previous | Next