Skip Nav
Home » Forums » SystemC Forum

Icon - KMLM List KMLM List

View email archives for the history of this mailing list.

List Home All Archives Dates Threads Authors Subjects
systemc-forum - Re: [systemc-forum] New to SystemC and Need some help Message Thread: Previous | Next
  • To: Sumit Adhikari <adhikari@xxxxxxxxxxxxxxxx>
  • From: saurabh jain <saurabh.jain.bits@xxxxxxxxx>
  • Date: Wed, 1 Feb 2012 22:54:09 +0530
  • Cc: Michael <michael6866@xxxxxxxxx>, "balyusuf @iastate.edu" <balyusuf@xxxxxxxxxxx>, "systemc-forum@xxxxxxxxxxxxxxxxxxx" <systemc-forum@xxxxxxxxxxxxxxxxxxx>
Send Email to systemc-forum@lists.accellera.org:
Send new message
Reply to this message
Sumit,

SystemC version: 2.2.0
Following error was encountered after doing "make all":

make[3]: Entering directory `/home/saurabh/SystemC/
systemc-2.2.0/src/sysc/communication'
g++ -I. -I. -I. -I../../../src    -Wall -DSC_INCLUDE_FX -O3 -c -o sc_signal.o `test -f 'sc_signal.cpp' || echo './'`sc_signal.cpp
In file included from ../../../src/sysc/datatypes/bit/sc_bv_base.h:50:0,
                 from ../../../src/sysc/datatypes/bit/sc_lv_base.h:56,
                 from sc_signal.cpp:102:
../../../src/sysc/datatypes/bit/sc_bit_proxies.h:716:16: error: reference ‘m_obj’ cannot be declared ‘mutable’ [-fpermissive]
../../../src/sysc/datatypes/bit/sc_bit_proxies.h:1193:18: error: reference ‘m_left’ cannot be declared ‘mutable’ [-fpermissive]
../../../src/sysc/datatypes/bit/sc_bit_proxies.h:1194:18: error: reference ‘m_right’ cannot be declared ‘mutable’ [-fpermissive]
../../../src/sysc/datatypes/bit/sc_bit_proxies.h:1196:18: error: reference ‘m_refs’ cannot be declared ‘mutable’ [-fpermissive]
In file included from sc_signal.cpp:102:0:
../../../src/sysc/datatypes/bit/sc_lv_base.h: In member function ‘sc_dt::sc_logic_value_t sc_dt::sc_lv_base::get_bit(int) const’:
../../../src/sysc/datatypes/bit/sc_lv_base.h:310:33: warning: suggest parentheses around arithmetic in operand of ‘|’ [-Wparentheses]

Regards,
Saurabh


On Wed, Feb 1, 2012 at 10:50 PM, Sumit Adhikari <adhikari@xxxxxxxxxxxxxxxx> wrote:
Saurabh :

Please share the error message.

Regards,
-------
Sumit Adhikari,
Institute of Computer Technology,
Vienna University of Technology,
Gußhausstraße 27-29,1040 Vienna
________________________________________
From: systemc-forum@xxxxxxxxxxxxxxxxxxx [systemc-forum@xxxxxxxxxxxxxxxxxxx] on behalf of saurabh jain [saurabh.jain.bits@xxxxxxxxx]
Sent: Wednesday, February 01, 2012 6:03 PM
To: Michael
Cc: balyusuf @iastate.edu; systemc-forum@xxxxxxxxxxxxxxxxxxx
Subject: Re: [systemc-forum] New to SystemC and Need some help

Hi Michael,

I am actually running on UNIX (Mint).

Regards,
Saurabh

On Wed, Feb 1, 2012 at 5:13 AM, Michael <michael6866@xxxxxxxxx<mailto:michael6866@xxxxxxxxx>> wrote:
Just go to OSCI website and download the right version. Systemc works on windows. You can use vs2005/2008/2010.

Thanks,
Michael

From: systemc-forum@xxxxxxxxxxxxxxxxxxx<mailto:systemc-forum@xxxxxxxxxxxxxxxxxxx> [mailto:systemc-forum@xxxxxxxxxxxxxxxxxxx<mailto:systemc-forum@xxxxxxxxxxxxxxxxxxx>] On Behalf Of balyusuf @iastate.edu<http://iastate.edu>
Sent: Tuesday, January 31, 2012 11:06 AM
To: systemc-forum@xxxxxxxxxxxxxxxxxxx<mailto:systemc-forum@xxxxxxxxxxxxxxxxxxx>

Subject: [systemc-forum] New to SystemC and Need some help

Hello All,


My name is Baraa and I am new to SystemC.  I am taking an embedded system class where we are going to learn how to use SystemC to model and simulate systems.  I am familiar with Linux, but I do not have it on my machine.  what is the best practice in getting SystemC working on a local machine? I mean is it best to install Linux? or there is an easier way to set it up on a windows?

Thanks in advance,

--
Baraa Alyusuf
Computer Engineering
Iowa State University



By Date: Previous | Next Current Thread By Thread: Previous | Next